Jump to content
ZloFenix Games
hangabur

Error 0xc000007b - can't open Zlorigin

Recommended Posts

I've ran Zclient+Zlorigin (for sims 4) on this computer for 2 months. I have Win10. After a reset last week (where I saved my Programfilesx86 sim data on my c: drive in windows.old), I can't open Zlo, but i can connect to zclient. I think my computer updated also but I'm not sure.

Continuously getting this error: "The application was unable to start correctly (0xc000007b). Click OK to close the application."

Troubleshooting I have done:

  • I am connected/authed to zclient.
  • I run as administrator.
  • I have uninstalled and reinstalled zclient and zlo many times. Zlo folder is in correct place.
  • I have DirectX version 12, the most recent one.
  • I installed the visual c++ redistrib file in the zlorigin folder in programfilesx86.
  • I have ran chkdisk /f /r.
  • I have ran /scannow. 
  • I have ran Dependency Walker on my Origin.exe and have a bunch of missing API-MIS-WIN .dll files, EXT-MS-WIN .dll files, and IESHIMS.dll is missing too.

I'm thinking about taking all my files off my comp and doing a clean reset but  I don't want to do that if there is something else I can do.

Help and guidance would be greatly appreciated. Thank you. 

@ZLOFENIX@Garry

Edited by hangabur

Share this post


Link to post
Share on other sites

maybe your Antivirus On ...if it's on Plz turn it off.
download again. and uninstall the old one and also delete data  from %appdata% & %programdata% install it again 

Share this post


Link to post
Share on other sites
1 час назад, Sajid300k сказал:

... and also delete data  from %appdata% & %programdata% ...

Do not forget to specify which folders to delete. :) Man will remove everything on your advice from appdata and programdata :crazy:

Share this post


Link to post
Share on other sites

0xc000007b... i think...

do you by any chance have origin installed on computer? I mean EA origin and not ZLOrigin?

also - try updating your .NET framework and installing c++ redistributables

Edited by NNmJYwg

Share this post


Link to post
Share on other sites

Thank you so much for the swift responses and your help!! :blush: @NNmJYwg @Indrid @Sajid300k

Antivirus off. Deleted appdata and program data for Zlorigin. Uninstalled zlorigin. I did not have origin but i uninstalled whatever Origin uninstaller was in the zlorigin folder. Reinstalled zlorigin. Reinstalled the files found here https://zloemu.net/faq?id=8  except for vcredist_arm.exe because the version was 'incompatible with my pc'.

@NNmJYwg, I already installed a bunch of c++ redists--namely the ones on the ZLo FAQ.

I have .NET framework version 4.7.2 (newest for Win10) but went ahead and downloaded version 4.5.2 - got this error: .NET Framework 4.5.2 or a later update is already installed on this computer.  Is this bad?

Still same error, 0xc000007b. Please advise ):

Edited by hangabur

Share this post


Link to post
Share on other sites

This error occurs when Windows can not fulfill all the conditions for a successful launch of the program.
Based on this, you can try the following:
1) Check the system for viruses.
2) Reinstall the program (Done).
3) Delete DirectX, Net Framework completely and install it again (you mentioned that you have these programs, but you did not say anything about reinstalling).
4) Disable antivirus and Windows Defende (you didn’t say anything about the last program).
5) Clean the registry with programs like CCleaner.
6) Use "Windows Recovery".
7) Remove all Visual C ++. After that, install all existing versions of VC ++ that correspond to the bitness of your operating system.
8) Run the program as an administrator (Done).

Share this post


Link to post
Share on other sites
On 10/29/2018 at 11:24 PM, hangabur said:

Thank you so much for the swift responses and your help!! :blush: @NNmJYwg Indrid Sajid300k

Antivirus off. Deleted appdata and program data for Zlorigin. Uninstalled zlorigin. I did not have origin but i uninstalled whatever Origin uninstaller was in the zlorigin folder. Reinstalled zlorigin. Reinstalled the files found here https://zloemu.net/faq?id=8  except for vcredist_arm.exe because the version was 'incompatible with my pc'.

@NNmJYwg, I already installed a bunch of c++ redists--namely the ones on the ZLO FAQ.

I have .NET framework version 4.7.2 (newest for Win10) but went ahead and downloaded version 4.5.2 - got this error: .NET Framework 4.5.2 or a later update is already installed on this computer.  Is this bad?

Still same error, 0xc000007b. Please advise ):

No - if a later update is already installed - 4.5.2 is too.

vcredist_arm can't be installed - that's for ARM processors.

Edited by NNmJYwg

Share this post


Link to post
Share on other sites
21 час назад, NNmJYwg сказал:

No - if a later update is already installed - 4.5.2 is too.

vcredist_arm can't be installed - that's for ARM processors.

windows10?

 

Share this post


Link to post
Share on other sites

Let him throw out his operating system in the window and buy a licensed Windows and update it from the Microsoft website. Tired of reading this. Are we here to support Windows?

Edited by Wuntila

Share this post


Link to post
Share on other sites
Quote

GreeenPNZ said : throw out your OS and buy licensed Windows and update it from Microsoft site. What are we doing here. Dealing with support for Windows?

My opinion @hangabur - check youtube there is working solution.

Edited by Brendo

Share this post


Link to post
Share on other sites

@GreeenPNZ @BrendoI have licensed win10, full updates.  While I understand where you are coming from, I’m trying to understand how these problems affect Zlorigin and how to fix it, and I was hoping someone here knew what specific thing I needed to run  zlo because all of my other programs are fine. I’ve checked so many windows guides but they do not fix my zlo problem. Tried everything in this thread and still nothing. Oh well. I guess I’ll clean reinstall Win10, and if that doesn’t work, I’ll try Fitgirl. 

 

Thanks for for the help guys. I appreciate it. 

Edited by hangabur

Share this post


Link to post
Share on other sites

Success. Clean reinstalled win10 last night, got errors when I ran Zlo saying that I needed msvcr120.dll and msvcp120.dll, so I copied those files from my battle.net folder and put them into the Zlorigin folder at Programfilesx86. Zlo runs. Can someone mark this thread as solved so anyone that needs it can see it for reference?

Edited by hangabur

Share this post


Link to post
Share on other sites

@Garry

11 hours ago, hangabur said:

Success. Clean reinstalled win10 last night, got errors when I ran Zlo saying that I needed msvcr120.dll and msvcp120.dll, so I copied those files from my battle.net folder and put them into the Zlorigin folder at Programfilesx86. Zlo runs. Can someone mark this thread as solved so anyone that needs it can see it for reference?

as you can see i got it, can someone mark the thread as solved?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...