Jump to content
ZloFenix Games
Rolik0

Рандомные ошибки и вылеты в БФ3

Recommended Posts

Недели 2 назад начались проблемы с БФ3, но проявляются они по-разному. Общее только то, что подключиться к любому серверу можно только с 2-5 раза.

Не подключается -просто белый экран - Game closed. На снимке я подключался 7 раз -безуспешно.

После нескольких попыток подключается, но: на одном сервере (и на одной карте) часто пропадает оружие, звук, игра просто вылетает. На другом сервере играешь 2 минуты - и вылетает с ошибкой ТАЙМАУТ или БЛЭЙЗ.

Но иногда все нормально и стабильно работает на всех серверах. А часто - на каком-то одном. 

Антивирь отключал и добавлял лаунчер, папку с игрой, з-клиент, файлы панкбастера и т.п. в исключения  - эффект тот же -НИКАКОЙ. Файерволов нет. Все запускается с правами админа.

Спойлер

image.thumb.png.35eabbea0d8b4ccdf64a239f924abc70.png

Спойлер

 

image.thumb.png.a7057b1e0700057f3d407d5d7a160e27.png

 

Спойлер

image.png.03aa61fbeb2c0758e6becadde71290fe.png

 

Понимаю, что проблемы могут быть с пакетами (т.е. с трассой интернета), но сделать уже ничего не получается. В логе лаунчера смущает обилие красных записей.

Если кто посоветует что-то дельное и комплексное - буду признателен.

Edited by Rolik0

Share this post


Link to post
Share on other sites

Снеси к чертям Нортон и добавь в винде в защитнике в исключения! 

Вообще во избежание конфликтов не рекомендуется устанавливать  сторонние антивирусы на десятку. У тебя ведь десятка?

Share this post


Link to post
Share on other sites

1. у меня Аваст

2. у меня 7ка, стоковый защитник отключен

3. переустановил панкбастер, лаунчер, кряк к БФ, злоклиент. Сначала стало заходить вроде бы даже и ничего так. Но вот после 2х часов игры снова пропало оружие. Это уже какой-то левый баг. Посмотрим, что будет с ошибками завтра.

Share this post


Link to post
Share on other sites

Ну с антивирем обычно просто - если все запустилось, значит антивирь уже не мешает.

Судя по ошибкам - клиент игры в целом ведет себя как-то странно, но в зклиенте проблем нету, раз 2 раза ехе появляется.

Share this post


Link to post
Share on other sites
В 11.09.2020 в 10:38, ZLOFENIX сказал:

Ну с антивирем обычно просто - если все запустилось, значит антивирь уже не мешает.

Судя по ошибкам - клиент игры в целом ведет себя как-то странно, но в зклиенте проблем нету, раз 2 раза ехе появляется.

У меня точно такие же проблемы, сначала не мог по три-четыре раза подключиться, потом вообще всё перестало работать с ошибкой BLAZE. Как выяснилось, всё дело в ланчере 34Н. Попробовал через другой(EasyLauncher), всё чудесно. Кстати, уже давно EasyLauncher перестал работать, а тут попробовал, вообще перестал вылетать при запуске, хотя вообще ничего не поменялось, кроме глюка 34Н.

Share this post


Link to post
Share on other sites
24 минуты назад, Russia85 сказал:

У меня точно такие же проблемы, сначала не мог по три-четыре раза подключиться, потом вообще всё перестало работать с ошибкой BLAZE. Как выяснилось, всё дело в ланчере 34Н. Попробовал через другой(EasyLauncher), всё чудесно. Кстати, уже давно EasyLauncher перестал работать, а тут попробовал, вообще перестал вылетать при запуске, хотя вообще ничего не поменялось, кроме глюка 34Н.

Привет) :)
Согласен с тем, что проблема есть.
Сегодня выпустил фикс, который возможно ее решит) :v:

Share this post


Link to post
Share on other sites
35 минут назад, 9XrIsToS9 сказал:

Привет) :)
Согласен с тем, что проблема есть.
Сегодня выпустил фикс, который возможно ее решит)

Фикс проблему решает, но только с оговоркой - если просто обновиться, то не помогает. Если скачать инсталлятор и установить ланчер в ту же папку что и до этого, не удаляя старую версию, то работает отлично. Во всяком случае, у меня сработала именно эта последовательность действий.

Share this post


Link to post
Share on other sites
1 час назад, Russia85 сказал:

Фикс проблему решает, но только с оговоркой - если просто обновиться, то не помогает. Если скачать инсталлятор и установить ланчер в ту же папку что и до этого, не удаляя старую версию, то работает отлично. Во всяком случае, у меня сработала именно эта последовательность действий.

UPD: Нифига ничего не решилось, через час опять вылеты с ошибкой:

Запуск игры
StateChanged State_GameRunning
StateChanged State_Init State_ClaimReservation 0
StateChanged State_NotLoggedIn State_ClaimReservation 0
Alert ERR_DISCONNECT_BLAZE 1 1 -1
StateChanged State_GameClosed

При этом EasyLauncher работает как ни в чем не бывало.

Share this post


Link to post
Share on other sites
1 час назад, Russia85 сказал:

UPD: Нифига ничего не решилось, через час опять вылеты с ошибкой:

Запуск игры
StateChanged State_GameRunning
StateChanged State_Init State_ClaimReservation 0
StateChanged State_NotLoggedIn State_ClaimReservation 0
Alert ERR_DISCONNECT_BLAZE 1 1 -1
StateChanged State_GameClosed

При этом EasyLauncher работает как ни в чем не бывало.

Жаль ((( Потому как я тоже сталкиваюсь с этой проблемой :cry:

Share this post


Link to post
Share on other sites

@ZLOFENIX Привет) Что скажешь по этому поводу ?
Потому что я уже хз, в чем трабла

Share this post


Link to post
Share on other sites

@Russia85 используя сильную телепатию чтоб угадать тебя на эмуле - нашел в логах: Missing DLL, активатор от бф3 на что-то ругается, какой-то длл ему не хватает, как вариант - может у тебя что-то сжирается антивирем? Ну ибо только эта причина может дать такой результат.

@9XrIsToS9 у тебя игры через как запускаются нынче? Все через зклиент или варианты?

Просто если через зклиент, то можно удалить dinput8 либу в папке игры и посмотреть что будет. Ибо если антивирь сжирает ZUpdaterx32 то это как раз подходящая причина для ошибки этой.

Share this post


Link to post
Share on other sites

@ZLOFENIX Никаких вариантов, делегирую это дело ZClient.
По поводу dinput8, зачекаю это дело как то :crazy:

Спасибо)

Edited by 9XrIsToS9

Share this post


Link to post
Share on other sites
5 часов назад, ZLOFENIX сказал:

@Russia85 используя сильную телепатию чтоб угадать тебя на эмуле - нашел в логах: Missing DLL, активатор от бф3 на что-то ругается, какой-то длл ему не хватает, как вариант - может у тебя что-то сжирается антивирем? Ну ибо только эта причина может дать такой результат.

Антивирусами не пользуюсь, защитник, дефендер, смартскрин и прочая лабуда отключена. Нетфреймворк обновлён, рантаймы тоже, дирекс тоже есть весь. Винда 10 Про 2009 установлена не далее как двое суток назад. Игра обновлена через злориджин примерно в это же время. По поводу библиотеки, сейчас попробую отследить куда кто обращается, и чего найти не может.

Share this post


Link to post
Share on other sites

@ZLOFENIX, вот полный лог обращений к файлам. Лог в формате Sysinternals Process Monitor, открывается ей же. Там все события от открытия ланчера до вылета игры.

Logfile.7z

Edited by Russia85

Share this post


Link to post
Share on other sites

Вроде ничего такого в логе нету.

Окей, предлагаю тогда через удаленку залезть, пиши в обратную на сайте эмуля, если не против.

Но у меня сейчас возможности очень ограничены, т.к. базу эмуля переделываю и не могу пересобрать файлы поэтому. Но вообще разобраться про missing dll хочется, т.к. там дикие косяки у еа, хотелось бы в них влезть и чутка разгрести.

Share this post


Link to post
Share on other sites

Моя история (продолжение).

После переустановки всего, скачал новую версию 34Лаунча. Ну, не знаю, что помогло, но заходить стало уже не с 5, а с 2-3 раза ) А вот теперь загадка: БЛЭЙЗ у меня пропала. Но подключение к серверам идет лишь бы как.  Сори, оружие пропадает либо сразу, либо через 1-10 минут, но стабильно на карте "Остров Уэйк" сервера РОСТОВ. Даже перезаход с перерегистрацией в ЗКлиенте не помог.

 

Спойлер

image.thumb.png.7a54f58761653757a5f29f838d4e91f2.png

image.png.e2db4a7fbfbf770b396554f9635308ba.png

  

Edited by Rolik0

Share this post


Link to post
Share on other sites

А вот моменты в середине - может у тебя длц не стоят, поэтому виснет на загрузке?

Share this post


Link to post
Share on other sites
2 часа назад, ZLOFENIX сказал:

А вот моменты в середине - может у тебя длц не стоят, поэтому виснет на загрузке?

да вот все стоит - уже ж год играю. Есть, кшно, подозрение, что файлы из какого-то длц повредились, поэтому некоторые карты не ввгружаются. Но, когда длц явно нехватало - при входе на такие карты был просто вылет игры. Знать бы, в какой из папок лежит этот длс и как их толком восстанавливать..

Спойлер

image.png.f1f61c4ff56bd4bc10670407ca88cdf6.png

 

Share this post


Link to post
Share on other sites

Папка Update в корне игры, в ней все допы лежат.

Share this post


Link to post
Share on other sites

да нет, чушь это: если бы ДЛС был сломан - на эту карту вообще не заходило. Но заходит на других серверах. Получается, все дело в серверах и/или потере пакетов при подключении к ним.

 

Share this post


Link to post
Share on other sites
3 часа назад, Rolik0 сказал:

да нет, чушь это: если бы...

Меньше текста! :stuk:

Дай скрин папки Update. Поглядим все ли допы установлены, а уж после будем гадать, если бы....

Edited by Garry

Share this post


Link to post
Share on other sites

Чот у меня идеи кончились уже что может быть еще.

Share this post


Link to post
Share on other sites

У меня +3 человека, у которых DISCONNECT_BLAZE 11-1. Просто с ходу, бац :(

Edited by 9XrIsToS9

Share this post


Link to post
Share on other sites

По моей маете я намутил следующее:

1. т.к. ошибки у меня были на Эльбрусе, Армор Шилде и Острове Уэйк, то переименовал папки Patch и Xpack1, Xpack3, заново закачал ставшие неактивными DLC и папку Patch (через кнопку "проверить обновления" в ЗлОриджин);

2. заново скачал 34Лаунчер и установил в папку с игрой.

Итого: Заходит на все серверы, пусть и не с 1го раза. Пару раз вылетало по тайм-ауту, но это уже дело в инете. Блэйз за 3 дня ни разу не было. Оружие пропадать перестало.

Как-то так. Надеюсь, эти меры оказались достаточными.

Edited by Rolik0

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...