Jump to content
ZLOFENIX Games

StarCraft Remastered under Wine


Recommended Posts

Hi

I am trying to run the game under Linux + wine64 (several latest versions checked), but ZClient 05.13.06.21 just fails with "ZI not runned or communication failure".

However, if instead I run wine with following command it starts the game, but the game is hardly usable to due to excessive logging.

WINEDEBUG=+relay WINEARCH=win64 WINEPREFIX=~/.wine64 wine64 ZClient.exe "c:\\Program Files (x86)\\StarCraft Remastered\\x86_64\\StarCraft.exe" &> wine.log

I suspect some race condition in ZClient which hides once "slow" run is done.

Link to post
Share on other sites

Should I update something besides just running ZClient again?

ZClient 05.16.15.40 behaves exactly as before - emits the same error unless run with +relay.

Link to post
Share on other sites

Now it shows ZClient 05.16.18.17

However, it fails to run again. This time with error "ZI not runned or communication failure1".

Not sure what that 1 now means.

BTW, shouldn't be spelled as "ZI not run" instead?

P.S.

As a workaround I now use

WINEDEBUG=+relay WINEARCH=win64 WINEPREFIX=~/.wine64 wine64 ZClient.exe "c:\\Program Files (x86)\\StarCraft Remastered\\x86_64\\StarCraft.exe" 2>&1 | tail -n 10

It works more or less ok, avoiding generating GBs/min in disk space.

 

As for Diablo - I am afraid with now current internet connection I will download it at the end of the next century :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...