Jump to content

ZClient Self Closes After Recent Update

Recommended Posts


- Whenever I run ZClient the program just closes now.

- It did work for a bit after the update though.

Evonix's Launcher:

- After the update for the time that Zclient was working, it said something about an invalid token whenever trying to connect to BF3 servers. It worked before the big update.

Windows 10, .Net Framework 4.8

Link to post
Share on other sites

Actually no the archived threads didn't help at all (plus I don't speak Russian sadly and tried to translate some). Besides these are all new issues since the big new update.

Link to post
Share on other sites
18 minutes ago, 9XrIsToS9 said:

You can launch BFs through the 34h launcher or through the website

Evonix's Launcher didn't updated for this ZClient update

Ok I'll use these new methods. However Zclient still crashes when run now. It completes the authentication then it just disappears. Any idea? (I need Zclient running to be able to connect)

Link to post
Share on other sites
28 minutes ago, ZLOFENIX said:

I will check it tomorrow, some same same problem, dunno why for now.

You do great work. No rush, take care.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...